View this article at: http://www.macnn.com/articles/13/09/17/supports.devices.as.old.as.iphone.3g/
Tuesday, Sep 17, 2013 9:18am
App Store now allows fetching 'last compatible versions' of iOS apps
Apple has enabled a new feature which lets people download the "last compatible version" of an app on the iOS App Store. Until now, only the most recent version of an app was available, which proved problematic for people with older hardware (and/or an older version of iOS) if compatibility requirements had changed. The new system will show a pop-up window in iOS, asking if they want to download an earlier app release.

The arrangement reportedly supports devices as old as the iPhone 3G. Apple may be worried about supporting older products in light of the iPhone 5s, which uses a 64-bit processor; until next month, apps written in 64-bit code won't be backwards compatible with 32-bit devices using iOS 6. Apple is promising to enable hybrid 32/64-bit binaries in October.